Incorrect Account Name Display Issue

Incident Report for ProPay

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 19:39 MDT

Investigating

We are aware of an issue causing some account names to display incorrectly. Our teams working to identify and resolve the issue as quickly as possible.
Posted Jun 12, 2026 - 14:55 MDT