Mastercard PPMC Debits

Incident Report for ProPay

Resolved

This incident has been resolved.
Posted Nov 17, 2023 - 12:22 MST

Update

Action has been taken to resolve the intermittent issues. If cardholders are having further issues, please contact us.
Posted Nov 17, 2023 - 12:21 MST

Update

Our teams have worked to address the issue. We are currently monitoring the traffic.
Posted Nov 17, 2023 - 12:02 MST

Investigating

We are having intermittent issues with Mastercard ppmc debits. We have engaged MasterCard and are working to resolve.
Posted Nov 17, 2023 - 09:11 MST
This incident affected: Production Processing Solutions (Direct Credit Card and ACH Processing) and Integrated Gateways (3rd Party Providers).