All reports have been delivered. We apologize for the inconvenience.
Posted Oct 07, 2025 - 09:29 MDT
Investigating
We are aware of an issue affecting the delivery of some ProPay Reports. Our teams are working to correct the issue and will provide updates as they are available. The reports are being delivered, but delayed.
Posted Oct 07, 2025 - 08:11 MDT
This incident affected: Production Supporting Solutions (xfer.propay.com - SFTP Reports).