Client Support phone line intermittent problems
Incident Report for ProPay
Postmortem

We have been able to identify and resolve several issues with our phone system and its interaction with our other tools.

Several weeks back, we increased the number of rings before it rolls to voicemail.

We have also worked to adjust some email routing policies that were preventing the delivery of e-voicemails.

We have taken steps to permanently change that configuration, which have corrected that erroneous behavior, to ensure that the team will be able to receive and respond to voice messages promptly moving forward.

We have also identified the various teams involved to resolve issues in the future, to reduce any similar problems that may come up.

We thank you for your patience as we have worked to resolve these issues.

Posted Jul 07, 2021 - 09:58 MDT

Resolved
All phone line and voice mail issues have now been corrected. We sincerely regret any negative impacts this has had in your efforts to contact us for support.
Posted Jun 16, 2021 - 14:00 MDT
Monitoring
Our VOIP service provider has deployed a change to improve the behavior of our phone system ringing, and so we believe we've resolved this part of our phone troubles. Currently, we still do not receive voicemail messages, and we're working with our internal support groups to get that corrected. This only applies to the "option 1" business hours line; you can still leave a message on the option 2 line if escalation support doesn't pick up, and expect a call back within a relatively short period of time (please always send in a ticket for escalations, too). We have continued to make it a priority to answer calls promptly. If you have to call back more than twice, please email and let us know, and we will arrange to call you back. Thank you for being patient as work through these technical problems.
Posted May 26, 2021 - 11:55 MDT
Update
We are continuing to investigate this issue.
Posted May 06, 2021 - 11:03 MDT
Investigating
The phone lines for Client Support have not been ringing the team reliably and consistently. We have a ticket open with our VOIP provider and hope to correct the problem as quickly as possible. We apologize for the disruption. We will be sure to prioritize our responsiveness to emails sent to clientsupport@propay.com.
Posted May 05, 2021 - 14:54 MDT
This incident affected: Production Supporting Solutions (Phones).