Flash Funds - Visa Direct is down

Incident Report for ProPay

Resolved

This incident has been resolved.
Posted Sep 07, 2023 - 09:49 MDT

Update

resolved
Posted Sep 07, 2023 - 09:48 MDT

Update

The issue has been resolved with Visa Direct.
Posted Sep 07, 2023 - 09:43 MDT

Update

We are continuing to investigate this issue.
Posted Sep 07, 2023 - 09:42 MDT

Investigating

We are aware of an issue affecting Flash Funds.
Our teams are working with Visa Direct to correct the issue and will provide updates as they are available.
Posted Sep 07, 2023 - 08:39 MDT
This incident affected: Production Processing Solutions (Credit Card and ACH Processing).