A fix has been implemented and we are monitoring the results.
Posted May 30, 2026 - 08:48 MDT
Investigating
We are aware of an issue that is preventing access to https://partnerportal.propay.com. Our teams are working to resolve the issue as quickly as possible.
Posted May 29, 2026 - 13:37 MDT
This incident affected: Production Processing Solutions (Websites, Mobile, and Card Readers).