ProPay Integration TEST Environment

Incident Report for ProPay

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 13:00 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 16, 2026 - 08:04 MDT

Investigating

We are aware of an issue affecting the test environment.
Our teams are working to correct the issue and will provide updates as they are available.
Posted Apr 15, 2026 - 15:26 MDT