Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 16, 2025 - 00:00 MDT
Scheduled
On Thursday, October 16th, between 00:00 and 05:00 (MT), ProPay will perform an upgrade to the production environment. Version 25.9.1 (October Release).
*We have made improvements to the chargeback process. These improvements include:
-Update Representment Timeline in Partner Portal from 60 Days to 25 Days for all card brands other than Mastercard -Update Representment Timeline for Mastercard card brand in Partner Portal from 60 Days to 40 Days -Update Chargeback Templates with New Fax ID and Address -Updated merchant Retrieval Request Notification emails to include accurate dollar amount -Show amount in dollars for chargeback reversal email templates from cents
*We have updated the response codes provided in ProPay signup response (TT01) in the event of KYC failure to be more accurate. These will guide the partner about the next action to take when KYC fails due to any incorrect business signup fields in signup request eg. invalid EIN, invalid business legal name or invalid business address.
This willl enhance the partner signup experience as based upon the correct feedback now the partner can retry the KYC failures with an attempt to make KYC successful and allow smooth ProPay merchant onboarding.
There will be a new Response elements in the business section of the signup response to indicate the presence of any action codes:
K151
Legal Name 12345 Address
and the new action code values and definitions are as follows:
*The InvNum value has been added in the following Partner Portal reports:
-Chargeback report -Failed Deposits and Collections Report -EFT Reject Report
*In SSO reporting, we have added the invnum (Invoice Number) value to existing ProPay reporting.
This value has been added into the following reports:
-Retrieval Request report, after the Transaction Number column -Chargeback report, after the Transaction column
Posted Oct 13, 2025 - 07:31 MDT
This scheduled maintenance affected: Testing Environments (Integration TEST Environment), Production Processing Solutions (Direct Credit Card and ACH Processing, Websites, Mobile, and Card Readers, Payment Facilitation - Heartland, Portico, Payment Facilitation - Global Payments API (GP API), Payment Facilitation - Cayan Genius), Production Supporting Solutions (xfer.propay.com - SFTP Reports, Bank Transfers, Phones, Regulatory Updates), and Integrated Gateways (3rd Party Providers).