ProtectPay ResultCode 207, ResultMessage "Gateway Internal System Error (account setup improperly)"
Incident Report for ProPay
Postmortem

This issue occurred due to some changes in Visa response codes that affected downstream translations into ProPay’s ProtectPay solution. ProPay teams updated the translations to handle the new response codes to enable them to be passed back to requesting systems correctly.

Posted Dec 14, 2021 - 09:30 MST

Resolved
This morning's 21.12.1 releases corrects this problem. We thank you for your patience!
Posted Dec 07, 2021 - 12:17 MST
Identified
Beginning in October, Visa began sending more specific response codes for some types of declines, replacing the generic 05 ("do not honor") code. The ProtectPay system failed to properly cover these new decline codes, resulting in some processing attempts now returning status 207 responses ("Gateway Internal system error") instead of the proper updated decline codes. In these declines, the API response of such transactions attempts include ResultMessage "Gateway Internal System Error (account setup improperly)".

We will correct this problem in the 2021.12.1 release on December 7th.

The following codes are new:

46 -- Closed account.
59 -- Suspected fraud.
82 -- Negative online CAM, dCVV, iCVV, or CVV results, or Offline PIN authorization interrupted (Note: previously, ProPay mapped this to 99 ("generic decline (international merchants)").
143 -- Customer data failed (corresponds to "6P" from Visa)

We will update the ProtectPay-API-Appendix-A-Responses document (section 2.4, "Status Codes Returned by Payment Method Issuer") to include these new codes. Reference link: https://www.propay.com/en-US/Documents/API-Docs/ProtectPay-API-Appendix-A-Responses

For partner systems that treat all ProtectPay responses with Transaction.ResultCode.ResultCode other than 00 (success) as issuer declines/rejections, it may be unnecessary to make any adjustments, but we recommend confirming that with your development teams.

Sample ProtectPay response JSON for this type of decline:
"Transaction":{"AVSCode":"T","AuthorizationCode":"","CurrencyConversionRate":1.0,"CurrencyConvertedAmount":46,"CurrencyConvertedCurrencyCode":"USD","ResultCode":{"ResultValue":"FAILURE","ResultCode":"46","ResultMessage":"Closed Account"},"TransactionHistoryId":"987654","TransactionId":"1","TransactionResult":"Declined","CVVResponseCode":"NotPresent","GrossAmt":null,"NetAmt":null,"PerTransFee":null,"Rate":null,"GrossAmtLessNetAmt":null},"RequestResult":{"ResultValue":"FAILURE","ResultCode":"46","ResultMessage":"Closed Account"}}]}
Posted Nov 04, 2021 - 12:24 MDT
This incident affected: Production Processing Solutions (Credit Card and ACH Processing, Websites, Mobile, and Card Readers).