Worldwide American Express processing outage
Incident Report for ProPay
Resolved
Amex processing has been solid since 3:02 p.m. EDT, with no more failures observed. Resolving issue.
Posted Oct 21, 2021 - 20:34 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2021 - 13:46 MDT
Update
We are continuing to investigate this issue.
Posted Oct 21, 2021 - 13:46 MDT
Investigating
We learned of a high rate of Amex processing failures as of about 2:15 p.m. EDT. It is our understanding that this was a system-wide outage, and the system looks to have recovered as of around 2:55 p.m. EDT. Our apologies for the late posting of this notification. We're continuing to monitor and will resolve this status update later today unless we become aware of additional problems.
Posted Oct 21, 2021 - 13:45 MDT
This incident affected: Production Processing Solutions (Credit Card and ACH Processing).