ProPay Integration TEST Environment Maintenance

Incident Report for ProPay

Resolved

The new certificate has been applied. All sites and services should once again be available in the test environment.
Posted Aug 07, 2026 - 11:27 MDT

Monitoring

The certificate is being updated on the Integration TEST environment. All services and sites may be unavailable during this timeframe.
Posted Aug 07, 2026 - 11:14 MDT
This incident affected: Testing Environments (Integration TEST Environment).