Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 24, 2024 - 03:00 MDT
Scheduled
At 3:00 a.m. (MT) on Thursday, October 24th, the database system will undergo its monthly maintenance. This maintenance will include a brief interruption of a few minutes to all sites and services as we move between data centers. We anticipate no more than 15 minutes of service interruption during this time frame.
Posted Oct 11, 2024 - 14:30 MDT
This scheduled maintenance affected: Testing Environments (Integration TEST Environment), Production Processing Solutions (Credit Card and ACH Processing, Websites, Mobile, and Card Readers), Integrated Gateways (Chase Paymentech - Orbital Gateway, Network Merchants, Web Collect, Meritus, CyberSource, Other 3rd Party Gateways), and Production Supporting Solutions (xfer.propay.com - SFTP Reports, Batch File Processing & Commissions, Bank Transfers, Phones, Regulatory Updates).