ProPay System Incident: Login Issues (propay.com)

Incident Report for ProPay

Postmortem

This issue was due to some custom content management system scripts that were incorrectly excluded from the production feature updates under a newer release paradigm. The scripts were identified and deployed to resolve the issue.

The release team has identified the source of the issue and the scripts will be included in future releases to prevent a recurrence.

Posted Nov 03, 2020 - 08:50 MST

Resolved

This incident has been resolved.
Posted Oct 19, 2020 - 15:07 MDT

Identified

We are aware of an issue that is affecting some user's ability to access the propay.com/en-Us/ site on mobile devices.

A fix is being applied currently to address this, and any affected merchants are able to login directly via mobile at https://epay.propay.com/login at this time, to ensure all users can access their accounts without incident.

We appreciate your patience and understanding as always!

clientsupport@propay.com
801-341-5312
Posted Oct 19, 2020 - 14:43 MDT
This incident affected: Production Processing Solutions (Websites, Mobile, and Card Readers).