ProPay Funding Delay Issue

Incident Report for ProPay

Resolved

This incident has been resolved.
Posted Sep 17, 2026 - 15:50 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2026 - 15:35 MDT

Investigating

We are aware of an issue of delayed funding for some merchants.

Our teams working to identify and resolve the issue as quickly as possible.
Posted Sep 17, 2026 - 15:22 MDT
This incident affected: Production Processing Solutions (Direct Credit Card and ACH Processing) and Production Supporting Solutions (Bank Transfers).