This incident has been resolved. We have corrected the issue and any chargebacks processed in error, have been refunded.
Posted May 01, 2026 - 10:02 MDT
Investigating
We are aware of an issue with the chargebacks. The Chargeback team is currently working with Development to resolve it. We will keep you posted as soon as there are updates.
Posted Apr 30, 2026 - 11:08 MDT
This incident affected: Production Processing Solutions (Direct Credit Card and ACH Processing, Websites, Mobile, and Card Readers, Payment Facilitation - Global Payments API (GP API), Payment Facilitation - Cayan Genius).