ProPay System Processing Issue

Incident Report for ProPay

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 14:04 MDT

Monitoring

Between 12:00pm and 12:30pm Mountain Time, some transactions timed out due to connectivity issues.
Our teams have identified and mitigated the issue, are monitoring for additional issues, and are researching the primary cause.
Posted Oct 15, 2025 - 12:58 MDT

Update

Updating Impact
Posted Oct 15, 2025 - 12:49 MDT

Investigating

We are aware of an issue that is preventing some transactions from being processed.
Our teams are working to resolve the issue as quickly as possible.
Posted Oct 15, 2025 - 12:45 MDT
This incident affected: Production Processing Solutions (Direct Credit Card and ACH Processing).