Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 15, 2024 - 00:00 MDT
Scheduled
Starting Oct 15th, 2024, ProPay will restrict the ability for boarding and servicing sub-merchant accounts via www.propay.com and epay.propay.com for ProFac payment facilitation partners. This access is for direct merchants for specific partner types. Profac Partners are not an approved group for this access.
Payment facilitation partners and their support teams currently using these sites to manage sub-merchant accounts will need to replace those actions using the reporting and management tools offered by ProPay such as:
*Single Sign On (SSO) pages *APIs *Reports (SFTP delivered via xfer.propay.com) *Notification Emails *Webhooks *ProPay’s new Partner Portal – a live data resource
We appreciate your partnership with us and strive to provide the best tools available to manage your business.
Please reach out to your relationship manager or the ProPay Client Support team with any questions or concerns.
Posted Sep 18, 2024 - 13:55 MDT
This scheduled maintenance affected: Production Processing Solutions (Websites, Mobile, and Card Readers).