Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 29, 2024 - 00:00 MDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 21, 2024 - 12:53 MDT
Scheduled
On Thursday, August 29th, between 00:00 and 05:00 (MDT), ProPay will perform platform maintenance, upgrading the live production system to version 24.7.1 (August Release)
We do not anticipate any interruption to services during this update window.
The update will include the following change:
*Improvements have been made to the epay.propay.com document upload process for the “Cardholder: Transaction Inquiry” page. The process to upload documentation has been streamlined, with an easier to navigate layout, and the addition of the ability to either accept an inquiry or provide support documentation, but not both.
Posted Aug 16, 2024 - 11:05 MDT
This scheduled maintenance affected: Testing Environments (Integration TEST Environment), Production Processing Solutions (Credit Card and ACH Processing, Websites, Mobile, and Card Readers), Integrated Gateways (Chase Paymentech - Orbital Gateway, Network Merchants, Web Collect, Meritus, CyberSource, Other 3rd Party Gateways), and Production Supporting Solutions (xfer.propay.com - SFTP Reports, Batch File Processing & Commissions, Bank Transfers, Phones, Regulatory Updates).