SEV2 (High) ProPay System Incident - Processing Timeouts
Incident Report for ProPay
Postmortem

This issue was due to a temporary downstream ISP network interruption. The lingering AMEX issues were due to a service in a non-functional state on a single application node, which was disabled, addressed and re-introduced.

Posted Nov 03, 2020 - 08:48 MST

Resolved
We have been able to monitor our server, and have not observed any further instances of timeouts at this time. We observed that other brands were marginally impacted during our observation window, and that primarily AMEX transactions were further impacted through 11:08am MST, but steps have been taken to resolve this, and we are not observing further issues at this time.

We appreciate your patience as always.
Posted Oct 19, 2020 - 11:35 MDT
Monitoring
Between 9:49-9:51 we experienced some disconnects from the processor that seem to be resolved as of now.

Our teams will continue monitoring the situation to be certain this connectivity issue is fully resolved, and will post additional updates pending that review.

We appreciate your patience as always.
Posted Oct 19, 2020 - 10:09 MDT
Investigating
We are aware of an issue that is intermittently preventing a percentage of transactions from being processed.

Our teams are working to fully identify and resolve the issue as quickly as possible.

We will provide regular updates until the situation is addressed.

clientsupport@propay.com
801-341-5312
Posted Oct 19, 2020 - 10:02 MDT
This incident affected: Production Processing Solutions (Credit Card and ACH Processing).