Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 13, 2025 - 00:00 MDT
Scheduled
On Thursday, March 13th, between 00:00 and 04:00 (MDT), ProPay will perform an upgrade to the production environment. Version 25.1.3 (March Release).
*** All services and sites may be unavailable during this time frame. ***
The update will include system stability updates and functionality improvements.
Posted Mar 11, 2025 - 11:09 MDT
This scheduled maintenance affected: Testing Environments (Integration TEST Environment), Production Processing Solutions (Credit Card and ACH Processing, Websites, Mobile, and Card Readers), Integrated Gateways (Chase Paymentech - Orbital Gateway, Network Merchants, Web Collect, Meritus, CyberSource, Other 3rd Party Gateways), and Production Supporting Solutions (xfer.propay.com - SFTP Reports, Batch File Processing & Commissions, Bank Transfers, Phones, Regulatory Updates).