Technical teams were engaged and service was restored for this site by 16:30MT.
Posted Aug 29, 2025 - 18:19 MDT
Investigating
We are aware of an issue affecting availability of our SFTP report site xfer.propay.com. Our teams are working to correct the issue and will provide updates as they are available.
Posted Aug 29, 2025 - 16:02 MDT
This incident affected: Production Supporting Solutions (xfer.propay.com - SFTP Reports).