SEV3 (Medium) ProPay System Incident - Processing Timeouts
Incident Report for ProPay
Postmortem

This incident was caused by an unresponsive service on a single application node.

It was removed from service, reviewed, refreshed and re-introduced. Monitoring detected the issue, but was delayed due to configured thresholds. We have adjusted those to target faster response and resolution times.

Teams are also reviewing the underlying cause & additional opportunities to improve resiliency to reduce impact of future similar scenarios.

Posted Nov 30, 2021 - 09:25 MST

Resolved
This incident has been resolved.
Posted Nov 26, 2021 - 11:53 MST
Monitoring
We are aware of an issue that is preventing some transactions from being processed.

Our teams were able to identify an unhealthy application node. They were able to quickly address the problem by removing this problem node from the pool. We do not anticipate any more related problems, but will continue to monitor the situation before resolving this incident.

clientsupport@propay.com
801-341-5312
Posted Nov 26, 2021 - 10:35 MST
This incident affected: Production Processing Solutions (Credit Card and ACH Processing, Websites, Mobile, and Card Readers).