Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 10, 2026 - 00:00 MDT
Scheduled
Starting at 12:00 a.m. (MT) on Thursday, September 10th, until 5:00 a.m. (MT) we will be performing updates to our TransIt boarding and device ordering platform.
We anticipate that there will be interruptions in attempts to board new merchants and order new devices during this time frame.
Posted Sep 09, 2026 - 13:27 MDT
This scheduled maintenance affects: Production Processing Solutions (Payment Facilitation - Global Payments API (GP API)).