Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 16, 2026 - 00:00 MDT
Scheduled
On Tuesday, June 16th, between 00:00 and 05:00 (MT), ProPay will perform an upgrade to the production environment 26.PI17.R3 (June Release)
*** All services and sites may be unavailable during this time frame. ***
*New Retry KYC API Call has been added to the ProPay XML API. The intent of this call is to provide an improved systemic process to allow a ProPay merchant to be successfully onboarded even after first KYC failure.
The documentation clearly explains the purpose and usage of the Retry KYC transaction and provides detailed definitions for all request elements, including account number, signer information, beneficial owner details, and business data along with their nested address structures.
It also outlines the response structure, including conditions under which different KYC response codes such as success or denial are returned, and describes the behavior of ActionCode for various entities involved in the KYC process.
Additionally, the documentation includes sample XML requests and responses for both successful and failed scenarios, ensuring consistency with existing API documentation standards and making it easier for partner developers to correctly implement and troubleshoot integrations.
*The ProPay Partner Portal has been updated to accurately reflect real-time chargeback status when viewing chargebacks and the Chargeback Report, and when using the “Take Action” option to accept or reject a chargeback
*Updates have been made to the epay.propay.com website to consolidate links and remove non-functional links, to improve customer experience
Posted Jun 11, 2026 - 12:39 MDT
This scheduled maintenance affected: Testing Environments (Integration TEST Environment), Production Processing Solutions (Direct Credit Card and ACH Processing, Websites, Mobile, and Card Readers, Payment Facilitation - Heartland, Portico, Payment Facilitation - Global Payments API (GP API), Payment Facilitation - Cayan Genius), Production Supporting Solutions (xfer.propay.com - SFTP Reports, Bank Transfers, Phones, Regulatory Updates), and Integrated Gateways (3rd Party Providers).