Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 16, 2023 - 03:01 MST
Scheduled
At 3:00 a.m. (MDT) on Thursday, November 16th, the database system will undergo its monthly maintenance. We anticipate no more than 15 minutes of service interruption during this time frame.
Posted Nov 01, 2023 - 08:22 MDT
This scheduled maintenance affected: Production Processing Solutions (Credit Card and ACH Processing, Websites, Mobile, and Card Readers), Integrated Gateways (Chase Paymentech - Orbital Gateway, Network Merchants, Web Collect, Meritus, CyberSource, Other 3rd Party Gateways), and Production Supporting Solutions (xfer.propay.com - SFTP Reports).