ProPay Funding Delay Issue

Incident Report for ProPay

Resolved

This issue is now resolved. Due to communication issues between systems, transaction statuses were not properly updating, resulting in them not being funded and sent to merchant bank accounts.
The issue was corrected and transactions were funded. Affected merchants should expect to see funds deposited in their bank accounts Monday if bank transfers are automatically initiated by Global Payments/ProPay and Tuesday if they are initiated by partner systems.

Technical teams are continuing to investigate the root cause and implement follow up action items to improve monitoring and remediation plans in the future.
Posted Nov 28, 2025 - 17:59 MST

Monitoring

Our teams have implemented a fix and are continuing to monitor the outcomes.
Posted Nov 28, 2025 - 17:27 MST

Investigating

We are aware of an issue of delayed funding for merchants using the Heartland/Portico/ProPay Payment Facilitation solution.

Our teams working to identify and resolve the issue as quickly as possible and will provide updates as we have more information.
Posted Nov 28, 2025 - 15:54 MST
This incident affected: Production Processing Solutions (Payment Facilitation - Heartland, Portico) and Production Supporting Solutions (Bank Transfers).