ProPay System Processing Issue - Canadian Accounts

Incident Report for ProPay

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 13:53 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2025 - 13:43 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 24, 2025 - 12:01 MST

Update

We are continuing to investigate this issue.
Posted Nov 24, 2025 - 08:54 MST

Investigating

We are aware of an issue that is preventing some transactions from being processed on Canadian accounts.
Our teams are working to resolve the issue as quickly as possible.
Posted Nov 24, 2025 - 08:52 MST
This incident affected: Production Processing Solutions (Direct Credit Card and ACH Processing).