SEV4 (Low) ProPay System Incident www.propay.com not loading
Incident Report for ProPay
Postmortem

This issue was caused due to some content management system licensing issues.

Once identified, changes were put in place to enable the site’s functionality across our web farm.

Work is in progress to update and expand our licensing model across all application nodes to prevent any similar future issues.

Posted Apr 20, 2021 - 08:51 MDT

Resolved
This incident has been resolved.
Posted Apr 06, 2021 - 12:26 MDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 06, 2021 - 12:25 MDT
Identified
We are aware of an issue where www.propay.com is not loading consistently.

Our teams are assessing the situation to implement a resolution.

Users of www.propay.com web processing solutions can login directly at https://epay.propay.com/login until this issue is resolved.

This issue is not affecting processing.
Posted Mar 30, 2021 - 21:29 MDT
This incident affected: Production Processing Solutions (Websites, Mobile, and Card Readers).