SEV4 (Low) ProPay System Incident: Database Maintenance
Incident Report for ProPay
Postmortem

This event resulted from a hardware issue on our storage array, causing intermittent database connection errors.

ProPay executed a database failover to an alternate data center to restore service and so the hardware could be updated and fixed.

Monitoring did detect & alert on the issue, however, our teams are exploring additional measures to improve awareness and failover actions.

With the hardware issue addressed, operations were moved back to the primary data center 4/20.

Posted Apr 20, 2021 - 08:56 MDT

Resolved
Traffic should be restored fully at this time. We appreciate your patience and understanding as always.
Posted Apr 17, 2021 - 09:28 MDT
Monitoring
We are aware of an issue that necessitates some unexpected database maintenance. We anticipate that resolving this maintenance matter will result in a brief down time, anticipated to be no more than 5 to 10 minutes, effective beginning 11:15AM EST.

We appreciate your patience and understanding in this regard.

We will provide regular updates until this is fully resolved.

clientsupport@propay.com
801-341-5312
Posted Apr 17, 2021 - 09:14 MDT
This incident affected: Production Processing Solutions (Credit Card and ACH Processing).