No anomalies have been identified during our review and everything appears to be functioning normally on our side
Posted Nov 06, 2025 - 08:58 MST
Monitoring
We will continue to monitor to ensure processing remains stable.
Posted Nov 06, 2025 - 08:57 MST
Identified
We’ve completed our internal review and did not find any issues on our end related to the decline behavior. Based on the available data, it appears the issue was caused by a timeout occurring on the partner’s side.
Posted Nov 06, 2025 - 08:55 MST
Investigating
We are currently seeing a higher-than-normal volume of transaction declines affecting some of our partners. Our development team is actively investigating the issue to identify the root cause and implement a resolution. We will provide updates here as more information becomes available.
Posted Nov 06, 2025 - 07:02 MST
This incident affected: Production Processing Solutions (Payment Facilitation - Heartland, Portico).