SEV4 (Low) ProPay Deposit Detail Report Delays
Incident Report for ProPay
Postmortem

The reporting delays were related to the database incident described here.

https://status.propay.com/incidents/ktfr1w396cj1

Due to the database timeouts, certain scheduled jobs were not run or prematurely exited.

Those processes were re-run and reports delivered later in the day.

Due to the nature of the issue, existing monitoring did not fully detect the scenario, so ProPay teams are exploring new ways to monitor for these conditions to enable more timely response for resolution.

Posted Apr 20, 2021 - 08:59 MDT

Resolved
We have identified the processes that were incomplete or did not run successfully and have re-run them. Any activity not covered in these transfer requests will be included in tomorrow's processes and reports.
Delayed Deposit Detail Reports should be delivered within the next 30 min.
Please submit any inquiries regarding this event or missing data to the Client Support team.
Posted Apr 17, 2021 - 18:07 MDT
Identified
Due to the database incident earlier this morning, it has come to our attention that some of the normal bank transfer request & Deposit Detail Report processes were interrupted, resulting in either partial or missed job completions.
Affected transfer jobs were those occurring between 00:00 and 10:00 MT on 4/17.

Our many existing monitors on these processes did not detect the scenario.
We have been researching the details and working to re-run the missed or incomplete processes in order to deliver the normally-expected Deposit Detail Reports.
This may result in more than one Deposit Detail Report being delivered for 4/17 - we expect any additional reports to have distinct data & both should be used.

This will not impact funding timelines in terms of credits to bank accounts. Any activity not picked up for bank transfer request today should get picked up in the next job runs.

We apologize for the interruption & missing reports and are working to deliver as many related reports as we are able.

clientsupport@propay.com
801-341-5312
Posted Apr 17, 2021 - 16:54 MDT
This incident affected: Production Supporting Solutions (xfer.propay.com - SFTP Reports, Bank Transfers).